05. 处理图形文件

Contents
05. 处理图形文件

介绍

本章介绍用于创建、打开和保存图形文件的命令。

您可以打开在其他 CAD 程序中创建的工程图文件或者保存文件以便在其他应用程序中打开它们。

这些命令支持以下文件类型:

  • DWG(工程图文件)
  • DWS(工程图标准文件)
  • DWT(工程图模板文件)
  • DXF(工程图交换格式)
  • DWF(设计 Web 格式)
  • SHP(形状文件)
  • FLX

您还可以:

要了解如何创建和管理布局,请参阅创建图纸和打印图形。

使用工程图选项卡

使用 DrawingTabs 命令来在工程图窗口区域顶部显示工程图选项卡。HideDrawingTabs 命令将隐藏工程图选项卡。

工程图选项卡提供了简单的方法来控制多个打开的工程图。

激活工程图的选项卡是白色的;所有其他工程图的选项卡都是灰色的。当您将鼠标悬停在选项卡上时,将出现一个工具提示显示工程图文件的完整路径和全名(仅限保存的工程图)。

选项卡栏的快捷菜单提供了用于控制选项卡的文件命令和选项。

当您将鼠标悬停在选项卡上时将出现包含已打开工程图的各工作区(模型或布局图纸)缩略图的预览面板。当您保存工程图或在各工作区之间切换时预览将相应更新。如果不能将所有缩略图都拟合到预览面板中,则可使用位于面板两端的箭头向右或向左滚动缩略图。

预览面板

您可通过拖动重新排序工程图选项卡。

如果打开的工程图数超出选项卡栏的显示范围:

  • 单击列示所有工程图  以显示所有打开工程图的列表并根据需要选择一个工程图。
  • 单击  或  以在选项卡栏上按所需方向移动选项卡。

工程图选项卡上文件名末尾的星号 (*) 表示该工程图未保存。

您可设置首选项来显示或隐藏工程图选项卡栏以及选择预览面板的显示模式。

您可以通过单击工程图选项卡、按住并将其拖动到主应用程序外部来将工程图显示为浮动窗口。浮动工程图窗口可让您在同一个会话中同时处理多个工程图。此外,您可以在另一块(第二个)显示屏上使工程图浮动。

注意:您可以从主应用程序访问所有浮动工程图窗口的命令窗口、菜单和功能区。

要添加新的工程图选项卡:

  • 单击最后一个工程图选项卡旁的 。

    如果未打开任何工程图,则工程图选项卡栏将在左侧显示加号图标。

    新工程图将使用默认模板工程图(类似于 SmartNew 命令)。

要关闭工程图选项卡:

  • 请执行以下操作之一:
    • 单击工程图选项卡上的  以将其关闭。
    • 将鼠标悬停在工程图选项卡上以关闭并单击鼠标中键。

    如果工程图自上次保存后已有更改,将出现一个提示询问您是否要保存所做的更改。

要切换到另一工程图:

  • 单击要显示的工程图的选项卡。

    – 或者 –

  • 按 Ctrl+Tab 可循环显示各打开工程图的选项卡。

要切换到工程图的特定工作区:

  1. 将鼠标悬停在特定工程图选项卡上。

    预览面板将出现在选项卡下,其中显示模型和所有布局图纸并高亮显示激活的工作区。

  2. 从预览面板中选择一个缩略图(模型或布局图纸)。

    将显示选定工作区。

要使用快捷菜单控制工程图选项卡:

  • 右键单击工程图选项卡或 图标,然后从快捷菜单中选择一个选项:
    • 新建。使用模板工程图开始新的工程图。
    • 打开。打开现有工程图。
    • 从云中打开。显示云存储控制板,可让您从其中一个云存储帐户选择工程图。
    • 保存。以当前文件名保存工程图。
    • 全部保存。保存所有打开的工程图。
    • 另存为。以另一名称保存工程图。
    • 关闭。关闭激活的工程图。
    • 保存到云。显示云存储控制板,可让您将当前工程图保存到其中一个云存储帐户。
    • 全部关闭。退出所有打开的工程图,但不退出程序。
    • 关闭其他工程图。关闭除激活工程图之外的所有其他打开的工程图。
    • 使成为第一个选项卡。使您右键单击的选项卡成为第一个工程图选项卡并使其成为激活的选项卡。
    • 使成为最后一个选项卡。使您右键单击的选项卡成为最后一个工程图选项卡并使其成为激活的选项卡。
    • 打开所在的文件夹。在单独的窗口中显示操作系统的文件管理器并指向选定工程图选项卡文件所在的文件夹。

  注意:如果您保存或关闭工程图且一个或多个工程图自上次保存后已被更改,则将出现一个提示询问您是否要保存所做的更改。

要重新排序工程图选项卡:

  • 选择一个选项卡并将其沿选项卡栏拖动到另一位置。

要将工程图选项卡移到第一个或最后一个位置:

  • 右键单击工程图选项卡并单击使成为第一个选项卡或使成为最后一个选项卡。

要从主应用程序使工程图选项卡浮动:

  1. 单击、按住并拖动工程图选项卡以将窗口拉到主应用程序外部。
  2. 将工程图选项卡拖放到同一屏幕上或另一个屏幕上(如果可用)。

按 Ctrl + Tab 键可在浮动工程图窗口之间导航。

要使浮动工程图返回到主应用程序:

  1. 单击并按住浮动工程图选项卡。
  2. 将工程图选项卡拖放到主应用程序中的工程图选项卡栏上。

要设置工程图选项卡的首选项:

  1. 请执行以下操作之一:
    • 单击工具 > 选项(或键入 Options)。

      在选项对话框中,单击系统选项 。

    • 键入 SystemOptions。
  2. 展开显示 > 工程图选项卡以设置以下选项:
    • 显示工程图选项卡。控制工程图窗口区域顶部的工程图选项卡的显示。
    • 在显示设置中,选择以下选项之一:
      • 列表视图。显示工作区的非图形列表。
      • 面板预览。在选项卡下显示各图形工作区(模型和布局图纸)的缩略图(默认值)。
  3. 单击确定。

访问方式

命令:DrawingTabs

开始新的图形

您可以从头开始或使用模板启动图形。

模板是包含您要用于新图形的设置的原型图形。模板使用 .dwt 扩展名。您也可使用 .dwg 文件或 .dxf 文件创建模板。您可以使用扩展名 .dwt 保存图形文件来创建模板。要在可用模板列表中显示新模板,请将其保存在模板文件夹下。

默认情况下,图形命名为 NONAME_n.dwg。

要使用模板启动新图形:

  1. 单击文件 > 新建(或键入 New)。
  2. 单击文件 > 新建(或键入 New)。
  3. 请执行以下操作之一:
    • 在开始页面上,单击从模板新建。
    • 在快速访问工具栏上,单击新建。
    • 在应用程序菜单中,单击新建。
    • 右键单击图形文件选项卡,然后选择新建。
  4. 导航到 .dwt 文件位置。

    您可以从本地和外部硬盘驱动器以及云存储帐户浏览文件。

    • 此 PC。显示系统文件夹、设备和网络位置。
    • 云存储。列出附加的云存储帐户。列表中的每个按钮都对应于一个云存储帐户。单击某个按钮可显示所选云存储中的图形和文件夹列表。您可以随时添加云存储服务或现有服务。
    • 浏览。打开经典文件打开对话框。
  5. 从列表中选择 .dwt 文件,然后单击打开。

要在不使用模板的情况下打开图形:

  1. 请执行以下操作之一:
    • 在开始页面上,单击新建。
    • 在菜单上,单击文件 > 新建

打开图形

您可以打开存储在计算机或网络中的工程图。

以下方法可用:

  • 使用开始页面
  • 使用打开对话框
  • 从 Windows 资源管理器中拖动图形并将其放在应用程序窗口中的图形区域以外的任何位置。

    注意:将图形拖动到图形区域中,将图形内容插入为图块。

  • 使用图纸集管理器打开图形图纸集中的图形。

只读模式

在网络环境中,多个用户可以随时尝试访问工程图。但是,一次只能有一个用户编辑工程图。当您尝试打开工程图时,软件会自动检查工程图是否被另一用户编辑,并允许您以只读模式访问工程图。

注意:如果尝试保存只读文件,您需要将文件保存到另一名称下。

使用编码打开

编码标准提供应用程序在屏幕上显示工程图上的文本所需的信息。不同的语言由不同的字符集组成,包括字母字符、数字和其他符号。

打开工程图时,您可以指定正确显示文件所需的编码标准。

要打开图形:

  1. 单击文件 > 打开(或键入 Open)。
  2. 单击文件 > 打开(或键入 Open)。
  3. 请执行以下操作之一:
    • 在开始页面上,单击打开。
    • 在快速访问工具栏上,单击打开。
    • 在应用程序菜单中,单击打开 > 打开。
    • 右键单击图形文件选项卡,然后选择打开。
  4. 导航到图形文件位置。

    您可以从本地和外部硬盘驱动器以及云存储帐户浏览文件。

    • 最近。显示您最近打开的文件列表。该列表包括本地驱动器中以及您的云存储帐户中的文件。
    • 收藏夹列表。显示您已保存的收藏工程图的快捷方式列表。该列表包括本地驱动器中以及您的云存储帐户中的文件。
    • 此 PC。显示系统文件夹、设备和网络位置。
    • 云存储。列出附加的云存储帐户。列表中的每个按钮都对应于一个云存储帐户。单击某个按钮可显示所选云存储中的图形和文件夹列表。您可以随时添加云存储服务或现有服务。
    • 浏览。打开经典文件打开对话框。
  5. 从下拉列表中选择文件类型。
  6. 从列表中选择图形。

    注意:或者,您可以在预览窗格中显示所选图形的缩略图,但并非所有文件格式都提供预览。

  7. 单击打开以加载工程图。

    如果另一用户正在编辑工程图,则会显示一条消息。单击是以打开文件而不对其进行修改。

要以只读模式打开工程图:

  1. 单击文件 > 打开(或键入 Open)。
  2. 导航到您的工程图。
  3. 从下拉列表中选择文件类型。
  4. 选择一个图形。

    注意:或者,您可以在预览窗格中显示所选图形的缩略图,但并非所有文件格式都提供预览。

  5. 单击打开以加载工程图。
  6. 单击打开旁边的箭头 右箭头,然后单击打开只读,以打开文件而不进行修改。

要打开带有编码的工程图:

  1. 单击文件 > 打开(或键入 Open)。
  2. 导航到您的工程图。
  3. 从下拉列表中选择文件类型。
  4. 选择一个图形。

    注意:或者,您可以在预览窗格中显示所选图形的缩略图,但并非所有文件格式都提供预览。

  5. 点击打开旁边的箭头 右箭头,然后单击使用编码打开。
  6. 在使用编码打开对话框中,选择应用程序应使用的编码。
  7. 选择只读以打开文件而不对其进行修改(可选)。
  1. 单击文件 > 打开(或键入 Open)。
  2. 在文件类型中,选择一种文件类型。
  3. 在查找范围中,导航到您的图形。
  4. 选择一个图形。

    预览区域展示选定图形的缩略图,但并非所有文件格式都提供预览。

  5. 单击打开加载图形,或者单击 右箭头 再单击打开(只读)打开文件,不做修改。

    如果另一用户正在编辑工程图,则会显示一条消息。单击是以打开文件而不对其进行修改。

  1. 单击文件 > 打开(或键入 Open)。
  2. 选择一个图形。
  3. 单击打开加载图形,或者从打开模型列表中选择打开(只读)打开文件,不做修改。

    如果另一用户正在编辑工程图,则会显示一条消息。单击是以打开文件而不对其进行修改。

要从经典打开系统文件对话框控制预览区域显示:

注意:此选项仅在经典打开系统文件对话框中可用。

  1. 单击文件 > 打开(或键入 Open)。
  2. 指定以下选项之一:
    • 强制预览窗格。在预览窗格中启用图形内容预览,而不考虑文件资源管理器设置。
    • 保持资源管理器设置。仅当在文件资源管理器设置中启用预览窗格时才显示此窗格。

    注意:仅当您再次显示打开对话框时,设置才会生效。

访问方式

命令:打开

菜单:文件 > 打开

键盘快捷键:Ctrl + O

键盘快捷键:Ctrl + O

键盘快捷键:命令 + O

保存图形

您可以保存图形供以后使用。

本节讨论的内容包括:

关于保存图形

您可以保存图形供以后使用。此外,您还可以自动保存和备份图形。

经常保存图形,以免在出现断电、系统意外关闭或其他技术事件时丢失工作。

图形文件的默认文件扩展名为 .dwg。此外,您还可以从另存为对话框中,将图形另存为图形交换格式 (.dxf)、图形模板文件 (.dwt),或者文件类型下拉列表中可用的其他格式。

您可以在选项对话框中更改默认文件格式。

每次您手动保存 .dwg 时,软件都会自动创建图形文件的先前版本的备份文件。默认情况下,图形备份文件与图形(.dwg 文件)保存在同一文件夹中,与图形具有相同的名称,但扩展名为 .bak。要恢复到先前版本,请使用不同的名称和 .dwg 文件扩展名重命名 .bak 文件。

用于保存图形的命令

以下命令可用于保存图形。选择适合您要完成的任务的命令。

  • 保存。如果图形未命名,使用 Save 命令利用当前文件名或指定的名称保存图形。
  • SaveAs。使用 SaveAs 命令可为未命名的工程图命名并保存、重命名当前工程图,或将其保存到新位置。

    如果工程图包含外部参考文件,请确保其路径已正确指定。

  • SaveAll。使用 SaveAll 命令保存当前窗口中的图形和所有其他打开的图形。

将图形保存到云存储中

您可以直接从云存储帐户保存和打开图形文件。

用于将图形文件保存和打开到云存储帐户的命令可在快速访问工具栏和应用程序菜单中找到。

要直接从云存储帐户保存和打开图形文件,请确保系统文件对话框已禁用。

要从云存储帐户直接访问工程图,请执行以下操作:

  • 将云存储帐户添加到“云存储”列表中
  • 确保已在系统选项(使用系统文件对话框选项)中禁用经典文件选择对话框。

要添加云存储帐户:

  1. 请执行以下操作之一:
    • 在快速访问工具栏上,单击新建。
    • 单击应用程序按钮 > 新建。
    • 右键单击图形文件选项卡,然后选择新建。
  2. 在文件选择对话框的云存储中,单击管理存储 。

    “新建”浏览器窗口列出了可用的云存储服务和授权帐户。

  3. 单击所需云存储旁边的添加新帐户 。
  4. 使用您的云存储凭据登录。
  5. 如果应用程序请求访问特定功能,请单击允许。
  6. 在桌面应用程序的文件选择对话框中,单击刷新 。

    云存储帐户将显示在云存储列表中。

保存图形

如果图形未命名,使用 Save 命令利用当前文件名或指定的名称保存图形。

要保存图形:

  • 单击文件 > 保存(或键入 Save)。

    图形以打开时指定的位置、名称和文件类型保存。

    如果图形未命名,另存为对话框将打开,以便您可以设置位置、名称和文件类型。

访问方式

命令:保存

菜单:文件 > 保存

键盘快捷键:Ctrl + S

键盘快捷键:Ctrl + S

键盘快捷键: Command + S

以另一名称保存图形

首次保存工程图后,您可以将其另存为其他名称或保存到其他位置。

使用 SaveAs 命令以指定的文件名和格式保存未命名的图形,或者重命名当前图形。此外,您可以指定不同的文件格式。

注意:一张工程图可以包含一个或多个其他文件的外部参考。当您将工程图保存到其他位置时,请确保正确指定外部参考文件的路径,并且所有参考文件在主工程图中都可用。

要以不同的名称保存图形:

  1. 单击文件 > 另存为(或键入 SaveAs)。
  2. 在另存为对话框中,导航到要存储图形文件的文件夹。

    您可以从本地和外部硬盘驱动器以及云存储帐户浏览文件。

    • 此 PC。显示系统文件夹、设备和网络位置。
    • 云存储。列出附加的云存储帐户。列表中的每个按钮都对应于一个云存储帐户。单击某个按钮可显示所选云存储中的图形和文件夹列表。您可以随时添加云存储服务或现有服务。
    • 浏览。打开经典文件打开对话框。
  3. 指定文件详细信息:
    • 从下拉列表中选择文件类型。
    • 键入文件的名称。
  4. 单击保存。
  5. 如果工程图包含带有相对路径的外部参考,则在将工程图保存到其他位置时会显示一条消息。

    指定一个选项:

    • 更新相对路径。应用程序会根据主工程图的新位置更新所有相对路径。但是,如果将主文件保存在不同的驱动器或网络位置,应用程序会将相对路径转换为完整路径。工程图存储外部参考的完整路径,包括根目录。
    • 不更新路径。相对路径不变。您可以在当前工作会话期间使用参考文件。但当您重新打开工程图时,不会加载外部参考。

    为避免丢失参考,选择更新外部参考文件的相对路径。

  1. 单击文件 > 另存为(或键入 SaveAs)。
  2. 在对话框中,指定文件详细信息:
    • 导航至要存储图形文件的文件夹。
    • 另存为:键入文件的名称。
    • 文件类型:选择文件类型。
  3. 单击保存。

访问方式

命令:SaveAs

菜单:文件 > 另存为

键盘快捷键:Ctrl + Shift + S

保存所有打开的图形

使用 SaveAll 命令保存当前窗口中的图形和所有其他打开的图形。

要保存所有打开的图形:

  • 单击文件 > 全部保存(或键入 SaveAll)。

    打开的图形将以打开时指定的位置、名称和文件类型保存。

    如果图形未命名,另存为对话框将打开,以便您可以设置位置、名称和文件类型。

访问方式

命令:SaveAll

菜单:文件 > 全部保存

查看和编辑图形文件特性

您可以查看并编辑当前图形文件的标准特性,并创建该文件的自定义特性。

标准图形特性包括描述图形主题或内容的作者名称、标题、主题、关键字和备注的详细信息。

您还可以定义图形的自定义特性。

要查看和编辑当前图形的标准特性,请执行以下操作:

  1. 单击文件 > 特性(或键入 DrawingProperties)。
  2. 在对话框的 摘要 选项卡上查看特性和类型,或根据需要编辑值。
  3. 可编辑字段包括作者、关键字、备注、标题和主题。
  4. 统计信息 区域通知有关图形文件创建日期、上次保存日期以及上次保存文件的用户的名称的信息。
  5. 单击确定。

要查看和编辑当前图形的自定义特性,请执行以下操作:

  1. 单击文件 > 特性(或键入 DrawingProperties)。
  2. 在对话框中,单击自定义选项卡。
  3. 在 名称 列中,选择一个框。
  4. 在列表中选择特性名称。
  5. 在 值 列中将显示特性值。
  6. 根据需要键入值或编辑值。
  7. 单击确定。

要向当前图形中添加自定义特性,请执行以下操作:

  1. 单击文件 > 特性(或键入 DrawingProperties)。
  2. 在对话框中,单击自定义选项卡。
  3. 单击编辑列表。
  4. 在对话框中将特性名称添加到列表。
  5. 单击确定。
  6. 在表的底部选择空行。
  7. 在 名称 列框中,键入新自定义特性的名称,或从列表中选择其名称。
  8. 在对应的 值 框中键入自定义特性的值。
  9. 单击确定。
  10. 添加到列表中的特性值将存储到用户的配置文件中,以将其用于其他图形文件中。

要从图形中移除自定义特性,请执行以下操作:

  1. 单击文件 > 特性(或键入 DrawingProperties)。
  2. 在对话框中,单击自定义选项卡。
  3. 突出显示自定义特性列表中的行。
  4. 单击删除。
  5. 将在图形文件中删除自定义特性及其值。
  6. 单击确定。

 标准图形文件特性将显示在 字段 对话框中的名称列表中。

访问方式

命令:DrawingProperties

菜单:文件 > 特性

关闭图形

使用 Close 命令关闭图形。软件保持打开状态。

要关闭工程图:

  1. 单击文件 > 关闭(或键入 Close)。

    如果工程图自上次保存后已有更改,将出现一个提示询问您是否要保存所做的更改。

  2. 单击是保存更改,或单击否放弃更改。

    如果图形未命名,另存为对话框将打开,以便您可以设置位置、名称和文件类型。

右箭头 或者,将鼠标悬停在图形选项卡上以关闭并单击鼠标中键。

访问方式

命令:关闭

菜单:文件 > 关闭

键盘快捷键:Ctrl + F4

键盘快捷键:Ctrl + F4

关闭所有打开的图形

使用 CloseAll 命令关闭所有打开的图形。

要关闭所有打开的图形:

  1. 单击窗口 > 全部关闭(或键入 CloseAll)。
  2. 如果一个或多个图形自上次保存以来有所更改,则会出现一条提示,询问是否为每个更改的图形保存更改。
  3. 单击是保存更改,或单击否放弃更改。
  4. 如果图形未命名,另存为对话框将打开,以便您可以设置位置、名称和文件类型。

访问方式

命令:CloseAll

菜单:窗口 > 全部关闭

退出

通过执行 Exit 命令,可以确保安全地结束每个工作会话。

退出:

  • 单击文件 > 退出(或键入 Exit)。

    如果自从上次保存后有一个或多个图形发生了变化,则系统将提示是否要保存对每个已更改的图形的更改。

    如果图形未命名,则将打开保存文件对话框,以便您设置位置、名称和文件类型。

    在保存了打开的图形后,当前的工作会话结束。
  • 单击文件 > 退出(或键入 Exit)。

    如果自从上次保存后有一个或多个图形发生了变化,则系统将提示是否要保存对每个已更改的图形的更改。

    如果图形未命名,则将打开保存文件对话框,以便您设置位置、名称和文件类型。

    在保存了打开的图形后,当前的工作会话结束。
  • 在应用程序菜单上单击退出(或键入 Exit)。

    如果自从上次保存后有一个或多个图形发生了变化,则系统将提示是否要保存对每个已更改的图形的更改。

    如果图形未命名,则将打开保存文件对话框,以便您设置位置、名称和文件类型。

    在保存了打开的图形后,当前的工作会话结束。

访问方式

命令:Exit

菜单:文件 > 退出

菜单:文件 > 退出

菜单:应用程序菜单 > 终止

键盘快捷键:Ctrl + Q 或 Alt + F4

键盘快捷键:Ctrl + Q 或 Alt + F4

键盘快捷键:Command + Q

输入与输出

使用输入与输出功能执行以下操作:

  • 将图形或图形的当前视图保存为矢量或光栅图像格式,包括 .dxf、.sat (ACIS)、.pdf、.bmp、.png、.jpg 和 .svg。
  • 加载由其它应用程序或 CAD 程序创建的 .dwg、.dxf 和 .sat (ACIS) 格式的图形文件。

  不使用输入命令,改用 InsertBlock 命令可在指定的插入点按旋转角度和比例因子插入 .dwg 和 .dxf 图形。您还可以使用 References、AttachDrawing 或 AttachImage 命令,将图形文件(.dwg)或光栅图像文件(例如 .bmp、.png、.jpg 和 .png)附着到图形中。

导出

使用 Export 命令,将文件保存为以下格式:

  • BMP(位图)
  • DGN (DesiGN)
  • DWF(设计 Web 格式)
  • DWFx(设计 Web 格式 XPS 文件)
  • EMF(Windows 加强型图元文件)
  • EPS (Encapsulated PostScript)
  • JPEG(联合图象专家组标准,一种位图图像格式)
  • PDF(可移植文档格式)
  • PNG(可移植网络图片,一种位图图像格式)
  • SLD(幻灯片)
  • STL(Stereolithography 文件)
  • SVG(可伸缩矢量图形)
  • TIF(标签图像文件)
  • UDATASMITH (Epic Games Unreal Datasmith)
  • WMF(Windows 图元文件)
  • STEP(产品模型数据交换标准)
  • IGES(初始图形交换规格)

输出包含激活的图形的可见部分(当前视图)。

要导出:

  1. 单击文件 > 导出 > 导出(或键入 Export)。
  2. 在对话框中,指定以下项目:
    • 保存位置:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
    • 另存为类型:选择要导出的文件类型。
  3. 单击保存。

访问方式

命令:输出

菜单:文件 > 导出 > 导出

输出 DXF 文件

使用 ExportDXF 命令可将当前工程图导出为包含 CAD 工程图中所有实体和对象的完整数据库信息的 DXF(工程图交换格式)文件。

DXF 文件用于与其他应用程序交换工程图数据。

DXF 文件可以是标准的 ASCII 文字文件,也可以是二进制文件。DXF 文件通常是指 ASCII DXF 文件,这类文件比 DXF 文件更为常见。二进制 DXF 文件比 ASCII DXF 文件小大约四分之一,前者的读写速度约为后者的五倍。

输出到 DXF 文件:

  1. 键入 ExportDXF。
  2. 在对话框中,指定以下项目:
    • 保存在:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
    • 保存类型:选择一种 .dxf 类型。
  3. 单击保存。

  注释:DXF 文件格式因版本而异。有些程序无法打开二进制 DXF 文件。

访问方式

命令:ExportDXF

输出 ACIS SAT 文件

可使用 ExportSAT 命令将当前图形中的选定区域或实体建模对象输出到 .sat 文件中。

输出到 ACIS SAT 文件:

  1. 键入 ExportSAT。
  2. 选择要输出的所有对象,然后按 Enter 键。
  3. 在对话框中,指定以下项目:
    • 保存在:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  4. 单击保存。

访问方式

命令:ExportSAT

从当前工程图创建 DGN 文件

您可以将当前 DWG 文件导出到 DGN 文件(DesiGN 格式)。受支持的版本包括 DGN V8。

ExportDGN 命令允许您配置导出选项并将当前工程图保存到 DGN 文件。

导出到 DGN 时,需要种子文件。种子文件是包含设置和属性的模板 DGN 文件。

导出流程会将 DWG 对象,如几何对象、图层或线条样式和颜色转换为相应的 DGN 级别、线型和颜色。

在开始导出流程之前,请计划以下内容:

  • 如何处理外部参考(如果有)
  • 如何处理 DGN 底图(如果有)
  • DWG 到 DGN 映射配置

您可以使用默认映射转换设置或定义新设置。DGNMapping 命令允许您管理映射配置设置。

DWG 到 DGN 转换表格

将 DWG 文件导出为 DGN 文件时,DWG 文件中的数据会转换为 DGN 文件中的相应数据。下表介绍了每种类型的数据在 DWG 与 DGN 文件之间如何转换。

DWG DGN 附注
2D 几何对象 2D 几何元素 –
图层 层 图层名称中的特殊字符会转换为 DGN 级别名称中的空格。
颜色 颜色 DWG 文件中的颜色会映射到其等效颜色或者(如果需要)映射到默认颜色。
线型 线型 标准 DWG 线条样式会转换为 DGN 文件中最接近的线条样式。自定义线条样式只能部分转换。
图块 单元格 自定义图块属性和图块特性只能部分转换。
单行注释和注释 文本和文本节点 文本对象会导出为 DGN 文件,但编辑文本可能会产生不同的结果。
表 表 表格对象会导出为由线条和文本组成的单元格对象。
字段 字段 字段值会导出为固定值文本。
标注 标注 标注值和关联会保留在 DGN 文件中。
图像 图像 以下图像文件类型会导出:.bmp、.cal、.tif、.png、.tga、.jpg、.gif、.rlc、.bil 和 .pcx。
DWG 参考 DGN 参考 根据您在 DGN 导出对话框中指定的选项,DWG 参考和嵌套 DWG 参考会按如下方式导出:
  • 个别 DGN 文件
  • 合并到 DGN 主要文件中
  • 不导出
代理对象 – 代理对象会导出到 DGN 文件。
3D 对象 – 3D 对象会导出到 DGN 文件。3D 对象不会导出。

注意:当在导出过程中出现不支持的对象时,会出现一条消息,您可以选择如何继续操作。

要将当前工程图导出为 DGN 文件:

  1. 单击文件 > 导出 > DGN 导出(或键入 ExportDGN)。
  2. 在 DGN 导出对话框的名称中,指定 DGN 文件的完整路径和名称。单击浏览以导航到新位置。
  3. 在 DWG 参考中,指定如何处理 DWG 参考:
    • 将所有 DWG 参考转换为 DGN 文件。将所有参考的工程图和嵌套文件导出为与 DGN 主要文件位于相同位置的 DGN 文件。DGN 文件的名称与原始 DWG 文件相同,但使用 *.dgn 扩展名。导出流程会检测是否已存在同名文件。您可以决定是否覆盖现有文件。
    • 将所有 DWG 参考绑定到 DGN 主要文件中。在单个 DGN 文件中导出主工程图文件以及参考和嵌套工程图文件。
    • 忽略 DWG 参考。只从主工程图导出实体并忽略参考文件。
  4. 在 DGN 参考中,指定如何处理 DGN 底图:
    • 将 DGN 底图导出为参考。启用后,会将参考文件导出为各个图块对象,并将 DWG 主要文件导出为单个 DGN 文件。
  5. 在指定种子文件中,指定要用于导出的模板文件。执行以下操作:
    • 从列表中选择一个预定义种子文件。

      – 或者 –

      单击 选择种子文件以在计算机上找到自定义种子文件。

  6. 指定单位转换使用主单位还是子单位作为基准。

    主单位和子单位表示适用的测量单位之间的关系,例如,英尺和英寸,或者米和毫米。子单位不能大于主单位。

    DGN 文件中定义的测量单位显示为默认单位。

    如果工程图中参考了指定的 DGN 文件的一个实例,则不能选择单位。

  7. 在 DWG 到 DGN 映射中,指定映射设置:
    • 在映射设置中,从现有映射设置列表中进行选择,或单击 DGN 映射设置管理器以创建新映射设置。请参阅 DGN 映射设置管理器对话框。

      映射设置预览区域会显示您在映射设置部分中指定的映射设置的预览。

  8. 单击确定。

访问方式

命令:ExportDGN

菜单:文件 > 导出 > DGN 导出

从图形创建 PDF 文件

通过将工程图导出为 PDF 格式可以在不同平台上查看工程图。

Adobe® 可移植文档格式 (PDF) 是一种中性文件格式,具有许多优点,例如:

  • 它可以基于矢量,因此可以进行高质量图像显示
  • 可以保留图层数据
  • 可搜索文本

由于 PDF 是一种中性文件格式,您可以使用它轻松地与客户、供应商、合作者和同事交换工程图。每个人都可以打开文件,复核和添加注释与附注,而不影响工程图对象。

您可以使用以下方法从软件生成 PDF 文件:

  • 将工程图导出为 PDF
  • 将 Print 命令与 PDF 打印机结合使用

使用 ExportPDF 命令将当前视图保存为 PDF 文件。该命令会显示 PDF 导出对话框,您可以在其中指定 PDF 文件选项,如文件名和位置、纸张大小和格式以及质量选项。

(可选)您可以保留以下导出设置:

  • 纸张大小和边距
  • 质量管理选项
  • 数据和字体管理选项
  • 保存到 PDF 文件属性数据
  • 保存回图形属性数据

注意:ExportPDF 命令创建的 PDF 文件是当前视图的预览。此命令将忽略图形比例。

要从工程图创建 PDF 文件:

  1. 单击文件 > 导出 > PDF 导出(或键入 ExportPDF)。
  2. 在对话框中,键入要创建的 PDF 文件的名称。单击浏览以浏览文件夹和名称。
  3. 在图纸中,选择要导出的图纸。在 PDF 文件中,每页图纸都是独立的页面。

    注意:单击全部清除可取消选择,单击全选可选择所有图纸。

  4. 在纸张大小中,选择以下项之一:
    • 标准以从纸张大小列表中选择标准格式。
    • 自定义以使用您选择的单位指定自定义格式的宽度和高度。
  5. 在边距中,您可以指定无法打印的顶部、底部、左侧和右侧边距的宽度。
  6. 指定用于生成 PDF 文件的选项:
    • 打印样式表格:将图层颜色或对象颜色映射到 PrintStyle 表文件(*.ctb 或 *.stb)中定义的规范。从 PrintStyle 表文件列表中,选择要应用的文件。有关打印样式的更多信息,请参阅管理打印样式表。
    • 打印透明度:确定在创建 PDF 文件时是否考虑对象透明度。
    • 单击其他选项以指定 PDF 质量选项。请参阅管理 PDF 文件的质量一章中的 PDF 选项。
  7. 在文档属性中,指定有关文档的信息:
    • 作者:输入创建文档的个人名称。
    • 关键字:键入关键字以使其在搜索过程中与 PDF 文档关联。关键字可用于缩小搜索范围。
    • 标题:键入文档的标题。各种搜索引擎都可在搜索结果列表中使用标题来描述文档。
    • 主题:键入文档的主题。
    • 创建器(自动生成):报告 PDF 文件的源应用程序。
    • 生成器(自动生成):报告由应用程序用来创建 PDF 文件的转换器引擎。

    在同一部分中,选择或清除:

    • 保存到 PDF 文档属性数据:使用指定的文档属性元数据增强 PDF 文件。
    • 保存回工程图属性数据:将指定的元数据存储在工程图文件的工程图属性中。现有数据可能会被覆盖。
  8. (可选)启用保留当前导出设置以便跨文件和工作会话存储质量管理和字体设置。
  9. 单击确定。

访问方式

命令:ExportPDF

菜单:文件 > 导出 > PDF 导出

基于图形创建位图文件

可使用 ExportBMP 命令将当前视图保存为一个位图 (BMP) 文件。

基于图形创建 BMP 文件:

  1. 键入 ExportBMP。
  2. 在对话框中,指定以下项目:
    • 保存在:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  3. 单击保存。

访问方式

命令:ExportBMP

基于图形创建 JPEG 文件

可使用 ExportJPG 命令将当前视图保存为 JPG 文件,一种光栅图像文件。

基于图形创建 JPEG 文件:

  1. 键入 ExportJPG。
  2. 在对话框中,指定以下项目:
    • 保存在:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  3. 单击保存。

访问方式

命令:ExportJPG

基于图形创建 PNG 文件

可使用 ExportPNG 命令将当前视图保存为 PNG 文件(可移植网络图形,一种位图化的图像格式)。

基于图形创建 PNG 文件:

  1. 键入 ExportPNG。
  2. 在对话框中,指定以下项目:
    • 保存在:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  3. 单击保存。

访问方式

命令:ExportPNG

基于图形创建 EMF 文件

[仅限 Windows® 版本]

[仅限 Windows® 版本]

可使用 ExportEMF 命令将当前视图保存为 EMF 文件(Windows 加强型图元文件,一种矢量和光栅图像格式)。

基于图形创建 EMF 文件:

  1. 键入 ExportEMF。
  2. 在对话框中,指定以下项目:
    • 保存在:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  3. 单击保存。

访问方式

命令:ExportEMF

基于图形创建 WMF 文件

[仅限 Windows® 版本]

[仅限 Windows® 版本]

可使用 ExportWMF 命令将当前视图保存为 WMF 文件。

基于图形创建 WMF 文件:

  1. 键入 ExportWMF。
  2. 在对话框中,指定以下项目:
    • 保存在:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  3. 单击保存。

访问方式

命令:ExportWMF

从图形创建 SVG 文件

使用 ExportSVG 命令将当前视图保存为 SVG 文件(可缩放矢量图形格式)。

要从图形创建 SVG 文件:

  1. 键入 ExportSVG。
  2. 在对话框中,指定以下项目:
    • 保存位置:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  3. 单击保存。

访问方式

命令: ExportSVG

从图形创建 EPS 文件

使用 ExportEPS 命令可以将当前视图另存为 EPS 文件(Encapsulated PostScript 文件)。EPS 文件将文本和其它图形对象指定为矢量。

从图形创建 EPS 文件:

  1. 在命令提示符中键入 ExportEPS。
  2. 在对话框中,指定以下项目:
    • 保存位置:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  3. 单击保存。

访问方式

命令:ExportEPS

从图形创建 Stereolithography 文件

使用 ExportSTL 命令将 3D 实体对象保存到 stereolithography (STL) 文件中。

要从图形创建 STL 文件:

  1. 在命令提示符中键入 ExportSTL。
  2. 指定要输出的 3D 实体对象。
  3. 指定是否要创建二进制文件还是 ASCII 文本文件。
  4. 在对话框中,指定以下项:
    • 保存位置:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
  5. 单击保存。

  在导出到 STL 文件之前使用 Union 命令统一单个 3D 实体对象。

访问方式

命令:ExportSTL

导入 Stereolithography 文件

使用 ImportSTL 命令导入 stereolithography 文件 (STL) 并将包含的几何体作为 ACIS 实体对象插入到工程图中。

要导入 STL 文件:

  1. 在命令提示符中键入 ImportSTL。

    对话框显示的文件类型设置为 .stl。

  2. 导航到要导入的 STL 文件,然后单击打开。

访问方式

命令:ImportSTL

将立体准面图文件导入为网格

使用 ImportSTLAsMesh 命令导入立体准面图文件 (STL) 并将包含的几何体作为子部分网格对象 (SubDMeshes) 插入到工程图中。

该命令类似于 ImporSTL 命令,但结果是不同的对象类型。

选中时,属性调色板会在网格部分中显示 SubDMesh 对象的 M 顶点计数和 N 顶点计数。

要导入 STL 文件:

  1. 在命令提示符中键入 ImportSTLAsMesh。

    对话框显示的文件类型设置为 .stl。

  2. 导航到要导入的 STL 文件,然后单击打开。

如果您使用 Explode 命令分解 SubDMesh,它将在名为 Faces 的面中转换为三面或四面曲面。

访问方式

命令: ImportSTLAsMesh

输入 DXF 文件

可使用 ImportDXF 命令读取 DXF 文件并将其在单独的图形窗口中打开。DXF 文件(图形交换文件)是一种标准的 ASCII 文本文件,其中包含 CAD 图形中的实体和对象的数据库信息。

也可以使用 Open 命令打开 DXF 文件,或者使用 InsertBlock 命令将 DXF 文件作为图块插入。

输入 DXF 文件:

  1. 键入 ImportDXF。
  2. 在对话框中,导航至要输入的 DXF 文件。
  3. 单击打开以加载 DXF 文件;或者单击 向右箭头 再单击打开(只读)以打开文件但不对其进行修改。

    如果您试图保存已有更改的只读文件,则会显示一条错误消息,提示您以其它名称保存文件。

访问方式

命令:ImportDXF

输入 DWF 文件

使用 ImportDWF 命令向图形中插入 DWF 文件。如果 DWF 文件受密码保护,则必须输入密码。

插入 DWF 文件:

  1. 在命令提示符处键入 ImportDWF。

    将显示该对话框,其中文件类型设置为 .dwf。
  2. 导航到要向其中插入的 DWF 文件,然后单击打开。
  3. 如果 DWF 文件受密码保护,出现提示时请输入密码。
  4. 为宽度和高度输入值。
  5. 指定在输入 DWF 文件时是否保留颜色索引。
  6. 选择要输入的图纸或者选择全部以输入所有图纸。
  7. 指定是否要输入三维 DWF 文件。

访问方式

命令:ImportDWF

导入 ACIS SAT 文件

使用 ImportSAT 命令读取 .sat 文件并将包括的 ACIS 实体对象插入到当前图形中。

要导入 ACIS SAT 文件:

  1. 键入 ImportSAT。
  2. 导航到要导入的 ACIS 文件,然后单击打开。

    该命令支持将 ACIS SAT 文件从 1.0.5 版导入到 27 版。

访问方式

命令:ImportSAT

将 PDF 文件导入为图块

使用 ImportPDF 命令将 Adobe® PDF 文件中的内容作为图块插入到工程图中。您可以插入多页 PDF 文档中的所有或选定页面。

如果 PDF 文件包含向量,它们将转换为工程图实体,比如直线、圆、椭圆和样条线。使用相同字体将文本行转换为文本实体(假定您的系统上可以使用 PDF 文件中嵌入的字体)。PDF 文件中的光栅图形作为图像文件存储在硬盘上,然后在您导入 PDF 文件的工程图中作为图像引用。

您还可使用批处理功能自动转换大量文件。

本主题讨论

要将 PDF 文件导入为图块:

  1. 单击插入 > PDF 导入(或键入 ImportPDF)。
  2. 单击导入 > PDF 导入(或键入 ImportPDF)。
  3. 键入 ImportPDF。
  4. 在对话框中的模式下,选择作为图块插入。
  5. 在 PDF 文件下,单击浏览。
  6. 在对话框中,选择一个 PDF 文件,然后单击打开确定。

    在对话框的 PDF 文件:

    • 文件路径下。显示您所选的 PDF 文件的完整路径和名称。
    • 参考路径。显示从 PDF 文件创建的图块中引用的图像文件的完整路径。

      单击浏览为引用的文件选择不同的文件夹。

  7. 如果 PDF 文件包含多个页面,请从图标列表中选择要作为图块插入的页面:
    • 单击图标以选择单个页面。
    • 单击一个图标,按住 Shift 键的同时,单击另一个图标以指定连续页面的范围。
    • 按住 Ctrl 键,然后单击多个图标以指定多个非连续页面。
  8. 在缩放比例下面,键入一个缩放系数,或者选择稍后指定以在关闭对话框之后在屏幕上指定缩放。
  9. 在旋转下面,为角度键入一个值,或者选择稍后指定,以在插入过程中在图形区域中设置旋转角度。
  10. 在缩放和旋转下指定以下信息:
    • 在缩放比例下面,键入一个缩放系数,或者选择稍后指定以在关闭对话框之后在屏幕上指定缩放。
    • 在旋转下面,为角度键入一个值,或者选择稍后指定,以在插入过程中在图形区域中设置旋转角度。
  11. 单击选项以为将 PDF 文件转换为图块插入设置首选项(请参阅下文以了解详细信息)。
  12. 单击确定 。
  13. 在图形区域中,为来自指定 PDF 文件页面中的图块指定插入点。
  14. 根据需要指定缩放系数和旋转角度。

注意:要将插入的图块拆分为其零部件对象,请使用 Explode 命令。

^ 页面顶部

要设置将 PDF 文件转换到工程图块的首选项:

  1. 单击插入 > 导入 PDF(或键入 ImportPDF)。
  2. 单击导入 > PDF 导入(或键入 ImportPDF)。
  3. 键入 ImportPDF。
  4. 单击选项。
  5. 在对话框中,激活或取消激活 PDF 文件转换的首选项:
    • 智能识别。指定转换器是否尝试识别 PDF 文件中代表圆、圆弧或椭圆的对象,以在插入到工程图的图块中创建圆、圆弧或椭圆。否则,这些对象将转换为样条线。请注意,启用智能识别会更耗时。
    • 忽略图像对象。指定是否转换光栅图像。光栅图像在插入到工程图的图块中作为外部存储的文件引用。使用 Reference 命令管理工程图中的图像参考。
    • 忽略路径对象。指定向量是否转换并插入到工程图中。向量(比如直线、圆弧和样条线)成为插入到工程图中的图块的一部分。
    • TrueType 文本。指定是否转换使用 TrueType 字体的文本实体并将其插入到工程图中。如果可能,工程图文本使用与 PDF 文本相同的字体。如果系统上没有对应的字体,则在工程图中使用活动的文本样式。
    • 忽略白色填充。指定转换的文件的几何体中包含的闭合边界是否由实体剖面线填充为白色。
    • 保留线条样式。指定是保留还是忽略导入的实体的线条样式属性。
    • 保留线宽。指定是保留还是忽略导入的实体的线宽属性。
    • 使用 PDF 图层。指定是否从 PDF 文件中存储的图层创建图层。如果 PDF 文件不包含图层,则会创建实体图层。
    • 创建实体图层。指定是否根据从 PDF 文件导入的实体创建图层。例如,PDF_Text、PDF_Images。
    • 使用当前图层。指定是否将所有指定的 PDF 实体导入到当前图层。
  6. 单击确定或取消。

    选项对话框中的设置将一直保留,直到您更改它们。

  7. 关闭对话框。

^ 页面顶部

要在批处理操作中将 PDF 工程图文件转换为 DXF 文件:

  1. 单击插入 > 导入 PDF(或键入 ImportPDF)。
  2. 单击导入 > PDF 导入(或键入 ImportPDF)。
  3. 在对话框中的模式下,选择批处理。
  4. 在 PDF 文件中:
    1. 单击浏览以指定包含要转换为 PDF 文件的 DXF 文件的源路径。
    2. 单击浏览以指定存储生成的 DXF 文件及其相关参考图像的目标路径。
  5. 在文件列表中,激活批处理过程中要转换的 PDF 文件。

    单击全选以标记列表中的所有 PDF 文件。

  6. 单击确定以开始对指定文件进行批处理。

    进度条显示转换进度。

^ 页面顶部

访问方式

命令:ImportPDF

菜单:插入 > 导入 PDF

功能区:插入 > 导入 > PDF

菜单:导入 > PDF 导入

将 DGN 文件导入为图块

使用 ImportDGN 命令将 DGN 文件(DesiGN 文件)中的内容作为图块插入到工程图中。.dgn 类型的文件由 MicroStation® 或其他 CAD 软件生成。受支持的版本包括 DGN V7 和 V8。

如果 DGN 文件包括多个设计模型,则您可选择要插入的模型。

您还可使用批处理功能自动转换大量文件。

本主题讨论如何:

要将 DGN 文件导入为图块:

  1. 单击插入 > 导入 DGN(或键入 ImportDGN)。
  2. 在命令提示符中键入 ImportDGN。
  3. 在 DGN 导入对话框中的模式下,选择作为图块插入。
  4. 指定是否要将文本节点分解成文本元素。

    如选中,DGN 文件中的文本节点对象将转换为简单注释,否则它们将转换为注释。

    文本节点是类似于注释的多行文本对象。

  5. 在 DGN 文件下,单击浏览。
  6. 在打开对话框中,选择一个 DGN 文件,然后单击打开。

    在 DGN 导入对话框中,DGN 文件下将显示以下信息:

    • 名称。显示您所选的 DGN 文件的完整路径和名称。
    • 路径。显示您从 DGN 文件创建的图块中参考的 DGN 文件的完整路径。
  7. 如果 DGN 文件包括多个设计模型,选择要作为图块插入的模型。

    在 DGN 文件中,一个工程图可分为多个设计模型,每个设计模型都是可在其中定义设计几何体的独立工作区。

  8. 在转换单位中,指定单位转换是使用主单位还是子单位作为基准。在 DGN 文件中定义的测量单位用方括号括起。

    主单位和子单位表示适用的测量单位之间的关系,例如,英尺和英寸,或者米和毫米。子单位不能大于主单位。选定单位将一对一地转换为工程图单位。

  9. 在缩放下,键入一个缩放系数,或者选择稍后指定以在关闭对话框之后在图形区域中指定缩放。

    将根据 DGN 文件中指定的单位(主单位或子单位)与当前工程图中使用的单位的比率来设置初始缩放系数。

  10. 在旋转下面,为角度键入一个值,或者选择稍后指定,以在插入过程中在图形区域中设置旋转角度。
  11. 单击选项以为将 DGN 文件转换为图块插入设置首选项(请参阅下文)。
  12. 单击确定 。
  13. 在图形区域中,为来自指定 DGN 文件中的图块指定插入点。
  14. 根据需要指定缩放系数和旋转角度。

  注意:要将图块拆分为其零部件对象,请使用分解命令。

^ 页面顶部

要在批处理操作中将 DGN 文件转换为 DWG 文件:

  1. 单击插入 > 导入 DGN(或键入 ImportDGN)。
  2. 在命令提示符中键入 ImportDGN。
  3. 在对话框中的模式下,选择批处理。
  4. 指定是否要将文本节点分解成文本元素。

    如选中,DGN 文件中的文本节点对象将转换为简单注释,否则它们将转换为注释。

    文本节点是类似于注释的多行文本对象。

  5. 在对话框中,选择批处理。
  6. 指定单位转换使用主单位还是子单位作为基准。在 DGN 文件中定义的测量单位用方括号括起。

    主单位和子单位表示适用的测量单位之间的关系,例如,英尺和英寸,或者米和毫米。子单位不能大于主单位。选定单位将一对一地转换为工程图单位。

  7. 在 DGN 文件中:
    1. 单击浏览以指定包含要转换为 DWG 文件的 DGN 文件的源路径。
    2. 单击浏览以指定存储结果 DWG 文件的目标路径。
  8. 在 DGN 文件中:
    1. 单击源以指定包含要转换为 DWG 文件的 DGN 文件的源路径。
    2. 单击目标以指定存储结果 DWG 文件的目标路径。
  9. 在文件列表中,选择批处理过程中要转换的 DGN 文件。
  10. 单击确定以开始对指定文件进行批处理。
  11. 单击开始以开始对指定文件进行批处理。

^ 页面顶部

访问方式

命令:ImportDGN

菜单:插入 > 导入 DGN

功能区:插入 > 导入 > DGN

相关主题

从当前工程图创建 DGN 文件

父主题

导出和导入

将 SVG 文件导入为图块

SVG 文件(可缩放矢量图形格式)将 2D 图形存储为基于 XML 的矢量图像。

无法直接打开 SVG 文件。您可以将几何体导入为图块,并在活动工程图中使用。

使用 ImportSVG 命令在活动工程图中插入 SVG 文件。

要将 SVG 文件导入为图块:

  1. 键入 ImportSVG。
  2. 在对话框中,单击浏览。
  3. 在文件选择对话框中,选择 SVG 文件,然后单击打开。

    在 SVG 导入对话框中的作为图块插入下:

    • 名称。显示 SVG 文件名称。
    • 文件路径。显示您所选的 SVG 文件的完整路径和名称。
  4. 在位置下,指定 X、Y 和 Z 的坐标值,或者选择稍后指定以在关闭对话框之后在屏幕上指定插入点。
  5. 在比例下:
    • 单击稍后指定以在插入期间定义图块大小。指定角选项,然后定义要在其中拟合图块的矩形的对角点。

      – 或者 –

    • 键入比例因子。比例因子:
      • 1:按原始大小插入图块。
      • 小于 1:将大小缩小为比例因子指定的原始大小的百分比。
      • 大于 1:增加大小。
  6. 在旋转下面,为角度键入一个值,或者选择稍后指定,以在插入期间在图形区域中设置旋转角度。
  7. 单击确定。

    图块出现在鼠标光标上。

  8. 使用 Ctrl 键在可用插入点之间切换。
  9. 单击某个点以放置图块。

访问方式

命令:ImportSVG

打开并保存 ESRI Shape (SHP) 文件

地理信息系统 (GIS) 软件产品使用 ESRI Shape 文件 (.shp) 来存储图形信息(例如陆地、街道、铁路、有建筑物的区域、分布网络、绿色区域、森林、河流、湖泊等)。

Shape 文件格式是一种由 Environmental Systems Research Institute, Inc. (ESRI) 开发的矢量数据格式,可用作 GIS 数据交换格式。

与图形文件格式(如 DXF 或 DWG)不同,Shape 文件不包含完整的图形信息。

构成地图、横向轮廓或其他地理计划的完整数据集在目录中分组,其中 Shape 文件显示几何矢量数据。其他文件类型存储属性和特性。

存储在单个 Shape 文件中的对象始终为一种类型:点、线或多边形(代表几何信息)。在 Shape 文件中,参考数据与原始对象相关联。

.shp 文件与数据库文件 (.dbf) 和索引文件 (.shx) 相关联,该文件存在于同一文件夹中,并且具有相同的名称。在 GIS 项目中,其他文件类型与 .shp 文件相关联。

打开 Shape 文件时:

  • 应用程序检测要导入的信息类型(点、线或多边形),并在图形中仅显示该类型的对象。您不能检查与几何对象关联的属性。

    注意:仅当 .dbf 和 .shx 文件存在于同一文件夹中且具有相同名称时,才打开 .shp 文件。

保存 Shape 文件时:

  • 您可以保存回 Shape 文件。您可以在此类文件中更改几何图形的位置和定位,但不能将具有属性的新几何图形插入到您写入的文件中。
  • 使用另存为以不同名称保存 Shape 文件。这将创建一个同名的关联 .dbf 和 .shx 文件。
  • 您可以使用另存为将图形另存为 Shape 文件。确保 Shape 文件仅包含一个相同类型的对象(点、线或多边形)。但是,这仅在您有可以处理导出数据的后处理软件时才有意义。

注意:  不要将 Shape 文件格式与字体源格式混淆,字体源格式共享 CAD 软件中使用的 .shp 扩展名。

要打开 ESRI Shape 文件:

  1. 单击文件 > 打开(或键入 Open)。
  2. 在对话框的文件类型列表中,选择 ESRI Shape 文件 (*.shp)。
  3. 导航至 .shp 文件并将其选中。
  4. 单击打开加载图形,或者单击  再单击打开(只读)打开文件,不做修改。

要以不同的名称保存 ESRI Shape 文件:

  1. 单击文件 > 另存为(或键入 SaveAs)。
  2. 在对话框中,指定以下项:
    • 在另存为类型中,选择 ESRI Shape 文件 (*.shp)。
    • 在文件名中,键入文件的名称。
    • 导航至要存储文件的位置。
  3. 单击保存。

基于图形创建幻灯片文件

可使用 ExportSLD 命令将图形的当前视图保存为幻灯片文件 (.sld)。

可以使用 ViewSlide 命令查看幻灯片文件。

可使用 LoadScript 命令显示幻灯片放映以展示图形的视图。

基于图形创建幻灯片文件:

  1. 在命令提示符处键入 ExportSLD。
  2. 在对话框中:
    1. 导航至要存储文件的文件夹。
    2. 在文件名中键入一个名称。
    3. 在保存类型中选择幻灯片 (SLD)。
  3. 单击保存。

  要提高幻灯片中的曲线实体质量,请使用 DisplayQuality 命令。

访问方式

命令:ExportSLD

查看幻灯片文件

可使用 ViewSlide 命令查看幻灯片文件 (.sld)。可以使用 ExportSLD 命令创建幻灯片文件。

当图形刷新时(例如使用其它命令时),您查看的幻灯片会消失。

查看幻灯片文件:

  1. 在命令提示符处键入 ViewSlide。
  2. 在对话框中,导航至要查看的幻灯片 (.sld) 文件。
  3. 单击打开。

    幻灯片随即会显示。
  4. 单击视图 > 刷新(或键入 Refresh)可清除幻灯片屏幕。

  可使用 LoadScript 命令显示幻灯片放映以展示图形视图的序列。

访问方式

命令:ViewSlide

打包图形

在实践中,可能会忘记包含依赖文件,例如参考、参考图像、参考 PDF 文件、字体文件、字体映射文件、打印样式文件和打印配置文件。

您可以创建 ZIP 文件或文件夹,用于将图形及其相关文件捆绑到一起。

例如,数据包用于随总图形一起将所有必备文件分发或发送给客户或项目合作伙伴,或者用于将这些文件存档。

本主题讨论:

将图形及其依赖文件打包

使用 PackAndGo 命令来创建包含当前图形及其依赖文件(例如参考、参考图像、参考 PDF 文件、字体文件、字体映射文件、打印样式文件和打印配置文件)的包。

您可以创建 ZIP 文件或文件夹,用于将图形及其相关文件捆绑到一起。

使用 Pack and Go 对话框的选项卡,可以指定要添加到包的文件。(可选)您可以显示包内容的摘要。

要创建包含图形及其依赖文件的数据包:

  1. 单击文件 > 导出 > Pack and Go(或键入 PackAndGo)。
  2. 在 Pack and Go 对话框中,为包文件列表指定视图模式:
    • 树视图:显示数据包文件的分级列表,按文件类型分组。
    • 表格视图:以表格格式显示包含的文件,同时显示文件名、路径、类型、DWG 文件版本、大小和日期等列。

    选择文件名前面的复选框,以指定要将文件包含到数据包中还是将其排除。默认情况下,所有依赖文件将包含在内。

  3. 单击添加文件以将更多文件添加到包。

    如果要包含与图形关联(而不是直接参考)的其他外部文件(例如自定义文件、文本文档或电子表格)。

  4. 单击设置以设置打包首选项。
  5. 在 Pack and Go 设置对话框中设置选项。请参阅设置图形打包首选项。
  6. 单击查看报告以查看包内容的摘要。

    报告对话框显示有关包内容的详细信息,并提供分发建议。报告可能写入到文本文件。

  7. 对于要包括的包注释,您可以键入要包括在包中的注释(例如项目状态信息)。
  8. 单击确定。
  9. 键入 ZIP 文件的文件名,然后单击保存。

访问方式

命令:PackAndGo

菜单:文件 > 导出 > Pack and Go

设置图形打包首选项

您可以创建 ZIP 文件或文件夹,用于将图形及其相关文件捆绑到一起。

使用 Pack and Go 设置对话框中的可用选项,您可以:

  • 创建 ZIP 存档文件或将文件收集到指定文件夹中。
  • 指定如何组织包中的文件和文件夹。
  • 将所有未使用的参考从您打包的图形中丢弃。

要设置图形打包首选项:

  1. 请执行以下操作之一:
    • 在菜单上,单击文件 > 导出 > Pack and Go。
    • 在图纸集管理器面板的图形图纸列表中,右键单击某个项目,然后从上下文菜单中选择 Pack and Go。
    • 键入 PackAndGo。
  2. 在 Pack and Go 对话框中,单击设置以设置打包首选项。
  3. 在 Pack and Go 设置对话框的打包类型和位置下面指定以下信息:
    • 打包类型:创建 ZIP 存档文件或将文件集合到指定文件夹中。
    • 文件格式:指定现有图形文件格式或保存为较早版本。
    • 目标文件夹:指定数据包的输出文件夹。
    • 文件名选项:指定输出文件夹中已存在具有相同名称的 ZIP 文件时采取的操作(提示更改文件名、覆盖文件或递增文件名)。
    • 文件名:显示 ZIP 文件名(与总图形名称相同)。
  4. 在路径选项下面,指定文件和文件夹在包(ZIP 文件或文件夹)中的组织方式:
    • 使用有组织的文件夹结构:基于文件结构创建分级文件夹结构。单击浏览以指定源的根文件夹。
    • 将所有文件放在一个文件夹中:如果不确定数据包收件人是否具有与您相似的文件夹结构,请使用此选项。
    • 原样保存文件和文件夹:重新创建现有文件的精确路径。
  5. 在操作下面,指定将图形打包之前执行的操作:
    • 绑定参考:使参考图形永久成为总图形的一部分。此选项会在总图形中将参考图形转换成块,并将相关符号(例如图层、线条样式定义、文本样式和尺寸样式)包含到图形中。该选项的作用与打包之前将 -References 命令与 Bind 命令配合使用相似。
    • 清除图形:将所有未使用的参考从您打包的图形中丢弃。该选项的作用与打包之前使用 Clean 命令相似。
  6. 在包含选项下面,指定以下信息:
    • 包含字体:将图形中所使用的字体包含到数据包中或将其排除。
    • 包含已卸载参照:指定是否保留至参考文件的链接,即使它们已被卸载并且在图形中不在可见。参考面板允许您卸载和重新加载文件参考。
  7. 单击确定。
  8. 在 Pack and Go 对话框中,单击确定以开始打包。

访问方式

Pack and Go 对话框:单击“设置”

从图形图纸集创建包

从图纸集管理器调色板中,您可以从整个图形图纸集或子集或从单个图形图纸创建包。

Pack and Go 选项在图纸集管理器上下文菜单中可用。

Pack and Go 对话框允许您指定要包含在包中的文件。

要从图形图纸集创建包:

  1. 在图纸集管理器中,打开要发送的图形图纸集。
  2. 在工程图图纸列表选项卡上,执行以下操作之一:
    • 要打包整个图形图纸集:右键单击图形图纸集。
    • 要打包图形图纸子集:右键单击图形图纸子集
    • 要打包指定的图形图纸或图形图纸选择:双击图形图纸。
  3. 从上下文菜单中,选择 Pack and Go。

    Pack and Go 对话框将显示。

  4. 在打包对话框中,指定要包括在包中的文件:
    • 在图形图纸选项卡上,通过选中图形图纸名称前面的复选框来指定要包括在包中的图形图纸。
    • 在树选项卡和表格选项卡上,添加或移除图形文件、依赖文件及任何其他文件。
  5. 单击设置以设置打包首选项。
  6. 在 Pack and Go 设置对话框中设置选项。请参阅设置图形打包首选项。
  7. 单击查看报告以查看包内容的摘要。

    报告对话框显示有关包内容的详细信息,并提供分发建议。报告可能写入到文本文件。

  8. (可选)在要包括的包注释中,键入要包括在包中的注释(例如项目状态信息)。
  9. 单击确定。
  10. 键入 ZIP 文件的文件名,然后单击保存。

为身份验证应用数字签名

您可以将数字签名与图形文件相关联,以便进行身份验证。

要签署图形文件,您必须从可靠的认证机构 (CA) 服务中购买签名证书:

  • 可靠的数字证书提供商可满足安全数字签名的要求。
  • CA 发布 PFX 文件和密码,以便在证书库中注册。
  • 您需要将根 CA 证书安装为受信任的应用。
  • 需要 3 类数字签名。

数字签名是附加到文件的加密信息块,可通过电子方式识别发起者。

由于已应用数字签名,数字签名还可以安全地指示文件是否被修改。

每个图形只能有一个签名。

注意:如果在您在签署文件并进行身份验证后修改该文件,则图形文件的数字签名将会无效。重命名图形文件不会使其数字签名无效。

您可以签署图形文件、验证身份验证以及移除您的签名。

本节讨论的内容包括:

签署图形文件以进行身份验证

使用 SignFile 命令,将数字签名安全关联到指定的图形文件。

数字签名可让您验证您的签名人身份。

您可以签署图形文件 (.dwg)、图形模板文件 (.dwt) 以及图形标准文件 (.dws)。

在在同一会话中修改并保存已签名的图形时,数字签名将保持有效。如果已签名的图形由签名人或其他用户在另一个会话中进行了修改,则该签名无效。

注意:要签署图形文件,您必须从可靠的认证机构 (CA) 服务中购买签名证书。

要签署图形文件以进行身份验证:

  1. 在命令提示符中键入 SignFile。
  2. 在对话框的要签署的文件下,指定要签署的图形文件。

    当前图形文件将出现在列表中。您可以添加其他文件、添加完整的文件夹、从列表中移除文件以及完全清除列表。

    注意:附加到所列文件的外部参考图形不会自动显示在列表中。

    使用下列选项以在一次签名操作中处理多个文件:

    • 包括子文件夹中的文件。将相对于当前图形文件位置的子文件夹中的图形文件添加到列表。
    • 添加文件。将图形文件添加到列表中。
    • 添加文件夹。将指定文件夹的所有图形文件添加到列表中。
    • 移除。从列表中移除选定的文件。
    • 清除列表。从列表中移除所有文件。
  3. 从选择数字 ID(证书)下的列表中,指定要用于验证身份的数字 ID。

    系统中至少需要一个有效的数字证书文件 (.pxf)。

  4. 此外,还可以在签名信息下添加详细信息:
    • 选择或清除添加时间戳。
    • 在注释中,写下与您身份验证相关的个人信息。
  5. 单击签署文件。
  6. 保存您签署的文件。

  状态栏右端的图标说明图形文件是否已签署。如果签名有效,将显示一个印记图标;如果签名无效,则印记图标上将显示一条划线。单击图标以运行 VerifySignature 命令。

访问方式

命令:SignFile

在图形中验证数字签名

使用 VerifySignature 命令验证附加到当前图形的数字签名。

命令使用主对话框和辅助对话框:

  • 数字签名验证对话框允许您检查数字签名是否有效,以及图形文件是否在签名后被更改过。
  • 数字签名详细信息对话框允许您查看有关数字签名的详细信息:
    • 文件名称和路径
    • 签名状态。显示数字签名是否有效以及图形文件是否在签名后被更改过。
    • 数字 ID 详细信息。签名人、证书颁发者、有效期、签名人的注释、签名日期等。

要在图形中验证数字签名:

  1. 在命令提示符中键入 VerifySignature。
  2. 在数字签名验证对话框中,使用以下选项:
    • 显示基本签名。显示在数字签名详细信息对话框中有关当前图形数字签名的信息。如果图形未签名,则此选项不可用。
    • 显示参考签名。显示在数字签名详细信息对话框中有关附加到当前图形的外部参考图形(参考)的数字签名信息。如果嵌套参考未签名,则此选项不可用。
    • 忽略参考警告。如果此选项已清除,每次将具有有效数字签名的外部图形作为参考附加到当前图形时,都会显示数字签名验证对话框。此对话框允许您查看有关参考图形签名以及可能的嵌套参考图形签名的状态和信息。
  3. 单击确定。

  状态栏右端的图标说明图形文件是否已签署。如果签名有效,将显示一个印记图标;如果签名无效,则印记图标上将显示一条划线。单击图标以运行 VerifySignature 命令。

访问方式

命令:VerifySignature

从图形中移除数字签名

使用 RemoveSignature 命令从当前图形或其他图形文件中移除现有数字签名。

注意:您不能从其他用户签署的文件中移除数字签名。

要从图形中移除签名:

  1. 在命令提示符中键入 RemoveSignature。
  2. 指定一个选项:
    • 当前图形。从当前图形中移除数字签名。
    • 指定文件。从对话框中,选择要从中移除数字签名的图形文件。
  3. 键入 Yes 以确认。

访问方式

命令:RemoveSignature

图形文件实用程序

本节介绍的图形实用程序可让您:

设置自动保存和备份选项

要保护您的图形文件,请使用自动保存和备份选项。

当图形正常关闭时,将删除自动保存文件。

要设置自动保存和备份选项:

  1. 单击工具 > 选项(或键入 Options)。

    单击应用程序菜单 > 首选项(或键入 Options)。

  2. 在选项对话框中,单击系统选项 。
  3. 展开自动保存与备份。
  4. 展开自动保存文件位置,为自动生成的已保存文件设置文件夹(.ds$ 类型的文件)。

    单击浏览以浏览文件夹。

  5. 展开自动保存/备份以设置以下内容:
    • 启用自动保存:自动将图形保存为自动保存文件(.ds$ 类型的文件)。您可以指定自动保存的间隔(以分钟为单位)。
    • 自动保存文件的文件扩展名:指定自动保存文件的文件扩展名(默认为 .ds$)。
    • 每次保存时保存备份:控制每次保存图形时是否创建备份副本(*.bak 类型的文件)。
    • 使用原始格式:指定备份文件是按原始图形文件版本还是按当前文件版本保存。
    • 增量保存:大概指定在图形文件中为增量保存分配的空间量(以百分比为单位),这会影响在需要完整保存之前可执行的增量保存操作的数量:
      • 如果该值等于 0,则每次都会执行完整保存。
      • 如果浪费空间的实际百分比小于或等于指定值,则将执行增量文件保存。
      • 如果浪费空间的实际百分比大于指定值,则将执行完整保存。

      有效值范围介于 0 和 100% 之间。默认值为 50%。

  6. 单击确定。

检查图形的完整性

Check 是一个诊断工具,用于检查当前图形并更正错误。对于检测到的任何错误,将在命令窗口中提供说明。

该命令会创建一个扩展名为 .adt 的 ASCII 文件,在其中包含针对检测到的错误的报告。.adt 文件与图形位于相同的文件夹中。

访问方式

命令:Check

菜单:文件 > 错误检查

恢复图形

Recover 命令可以部分恢复受损的图形文件。在打开现有图形遇到困难时,可使用此工具。文件损坏可能仅限于部分图形;此工具可以帮助从文件中抢救未受损的图形单元。

恢复受损的图形:

  1. 单击文件 > 恢复(或键入 Recover)。
  2. 在对话框中,选择受损图形的文件名,然后单击打开。

访问方式

命令:Recover

菜单:文件 > 恢复

使用图形恢复管理器恢复图形

如果系统意外终止(例如由于电源故障、硬件问题或软件问题),图形恢复管理器会恢复图形文件。下次启动应用程序时,会打开图形恢复管理器调色板。

当您在打开现有图形时,或如果您想检查计算机上是否有可恢复的图形文件时,您也可以使用 DrawingRecovery 命令。

图形恢复管理器调色板包含三个部分:

调色板区域 说明
恢复文件树视图 显示要作为根条目恢复的文件。对于每个文件,将列出可用的自动保存和备份文件。
详细信息列表 显示有关图形文件的详细信息:文件名、文件夹、创建日期和时间、上次保存日期和时间、文件大小和最后编辑该文件的用户姓名。
预览区域 显示选定图形文件的预览。


您可以使用调色板顶部的以下工具栏按钮:

按钮 说明
详细信息视图切换 打开和关闭调色板的详细信息区域。
预览切换 打开和关闭调色板的预览区域。


图形恢复管理器支持以下文件类型:

文件类型 说明
.dwg、.dws、.dwt 图形文件、图形标准文件、图形模板文件。这些文件可恢复。
.ds$ 自动保存文件。这些是不时自动创建的备份文件。使用 Options 命令指定自动保存自动保存文件扩展名之间的分钟数:在选项对话框中,单击系统选项 > 自动保存和备份。
.bak 备份文件。每次手动保存图形文件时,这些文件都会在与当前图形文件相同的文件夹中创建。使用 Options 命令打开和关闭备份文件的创建:在选项对话框中,单击系统选项 > 自动保存和备份。
filename_recover_yyyy-mm-dd.dwg 恢复文件。意外失败或崩溃后会出现这些文件,其中 filename 表示原始文件名,而 yyyy-mm-dd 则指定出现问题的日期。

  有关自动保存和备份的详细信息,请参阅设置自动保存和备份选项。

要使用图形恢复管理器恢复图形:

  1. 请执行以下操作之一:
    • 在菜单上单击文件 > 图形恢复管理器。
    • 在应用程序菜单上单击管理 > 图形恢复管理器。
    • 在命令提示符中键入 DrawingRecovery。
  2. 在调色板上的恢复文件中,使用以下选项:
执行 说明
选择根文件名条目,然后右键单击全部打开(或双击根条目)。 打开根条目中存在的所有文件。要恢复其中打开的文件,请将其另存为 .dwg 文件。
在根条目下面选择一个文件名,然后右键单击打开(或双击文件名)。 打开指定的文件。要恢复该文件,请将其另存为 .dwg 文件。
在根条目下面选择一个文件名,然后右键单击属性。 显示操作系统提供的图形文件属性对话框。
选择根文件名条目,然后右键单击移除。 从恢复列表中移除文件条目。如果您不需要恢复文件,请使用此选项。将保留自动保存和备份文件。将删除恢复文件。

要隐藏图形恢复管理器调色板:

请执行以下操作之一:

  • 在命令提示符中键入 HideDrawingRecovery。
  • 单击关闭调色板按钮。

  如果您在解决所有受影响的图形之前关闭图形恢复管理器,请使用 DrawingRecovery 命令重新打开调色板。

访问方式

命令:DrawingRecovery

菜单:文件 > 图形恢复管理器

应用程序按钮:管理 > 图形恢复管理器

抛弃未使用的参照

Clean 命令将从工程图移除未使用的参考。您可移除块定义、实体组、图层、定义的工程制图样式(例如线条样式、文本样式、尺寸样式和富线样式)以及其他参考,只要它们未被工程图文件中的其他定义或实体参考。

可以将该命令应用于所有部件类型,也可应用于选定的部件类型。

抛弃未使用的参照可以减小图形文件的大小。在将图形存档或备份之前,可以使用此命令。

Clean 命令不会删除所定义的视图或坐标系,因为它们从来不会被图形中的其它部件参照。要删除定义的视图,请使用 Views 命令。要删除所定义的坐标系,请使用 CCS 或 CSStyle 命令。

不能放弃以下选项:

  • 图层 0(工程图中必须至少有一个图层)
  • 线条样式“连续”、“ByLayer”和“ByBlock”
  • 文字样式“Standard”
  • 表格样式“Standard”
  • 富线样式“Standard”
  • 包含工程图实体的图层
  • 工程图实体参考的线条样式、文字样式、表格样式和富线样式
  • 激活的图层、线条样式、文字样式、表格样式和富线样式

要丢弃未使用的参考:

  1. 单击格式 > 清理(或者键入 Clean)。
  2. 在对话框中,选择显示未参考的实体。
  3. 设置选项:
    • 删除相关实体: 移除未被其他实体参考的项目及其子项目。
    • 删除之前确认: 对于要移除的每个项目显示确认清理对话框。
  4. 单击删除 以丢弃选定项目。
  5. – 或者 –
  6. 单击全部删除 以丢弃所有未使用的项目。

访问方式

命令:Clean

菜单:文件 > 清除

比较工程图

在处理项目时,您可能会从同事处收到修改过的工程图。无论有多少更改、更改是大还是小,查看更改都是一项耗时的任务。但是,有必要查看后续版本或修订版中的更改。

DrawingCompare 命令允许您直观地比较两个工程图并自动检测差异。该命令可在模型模式和图纸模式下工作。

您可以比较工程图的较旧修订版与最新修订版或是比较两个类似工程图。该命令可识别并突出显示添加、删除或修改对象的差异。

比较结果使用不同的颜色显示在当前工程图中。

在工程图比较控制板中,您可以更改每个对象类别的颜色,并使用修订云线突出显示差异。

  • 仅在当前工程图中的实体(已删除的实体)
  • 仅在比较工程图中的实体(新实体)
  • 两个工程图中的对象以灰色显示

修订云线还包括 3D 等轴测视图中的更改。

只要比较处于活动状态,该工具便会检测当前工程图中出现的所有修改。您可以浏览并缩放每个差异,并决定是否在工程图中保留对象。

将结果导出为单独的工程图或将新对象合并到当前工程图中。

注意:比较预览中不考虑冻结图层上的对象。

DrawingCompare 命令显示工程图比较调色板。

比较限制

工程图比较有以下限制:

  • 支持以下文件类型:DWG、DXF、DWT、DWS。
  • 不考虑以下实体类型:OLE 实体、相机、地理数据、GIS 实体、外部参考,比如 DGN 底图、DWF 底图、PDF 底图、图像、坐标模型和点云。
  • 不检测属性更改,比如嵌套图块内的 ByBlock 和 ByLayer。
  • 不会在线条和多段线之间产生差异。
  • 修订云线不包括 3D 等轴测视图中的更改。
  • 不允许您将比较结果与第三个工程图进行比较。
  • 忽略线宽、线条样式和颜色。
  • 分解图块。

要显示“工程图比较”调色板:

  • 请执行以下操作之一:
    • 在菜单上,单击协作 > 工程图比较。
    • 在功能区上,单击协作 > 实用程序 > 工程图比较。
    • 在命令提示符中键入 DrawingCompare。

要隐藏“工程图比较”调色板:

  • 在命令提示符中键入 HideDrawingCompare。

要比较两个工程图:

  1. 打开基本工程图。
  2. 在命令提示符中键入 DrawingCompare。
  3. 在工程图比较调色板上,单击加载文件。
  4. 在打开文件对话框中,浏览到要与当前图形进行比较的文件。
    • 最近。显示最近打开的图形的列表。
    • 此 PC。显示系统文件夹、设备和网络位置。
    • 云存储。允许您从一个云存储中选择图形。使用管理存储 将云存储服务添加到列表中。
    • 浏览。显示经典的打开对话框。
  5. 单击打开。
  6. 在工程图比较调色板上,单击切换比较。

    图形区域会在扩展视图中显示比较结果。

示例:

  • 绿色圆圈 – 仅在当前工程图中
  • 红色圆圈 – 仅在比较工程图中
当前图形 比较工程图 比较结果

要将对象从比较工程图导入到当前工程图中:

  1. 在工程图比较控制板上,使用向右和向左箭头浏览差异。
  2. 从弹出菜单中,选择合适的选项:
    • 导入。将缺失对象从当前选定差异导入到当前工程图中。
    • 全部导入。将所有缺失对象从比较工程图导入到当前工程图中。

    对象会添加到当前工程图中并自动变成灰色。

要导出比较结果:

  1. 在工程图比较调色板上,单击导出比较结果。
  2. 在对话框中,指定以下项目:
    • 保存位置:导航至要存储文件的文件夹。
    • 文件名:键入文件的名称。
    • 另存为类型:选择要导出的文件类型。
  3. 单击保存。

工程图比较调色板

工程图比较调色板将用于比较两个版本的工程图的工具分组在一起。

在工程图比较调色板中,您可以:

  • 加载要与当前工程图进行比较的工程图。
  • 独立于线条样式和线条颜色查看两个版本之间的差异。
  • 浏览差异,分析并决定是否保留更改。
  • 刷新当前工程图视图
  • 控制图形区域中差异的展示
  • 控制比较结果中重叠实体的显示
  • 在图形区域中显示或隐藏剖面线和文本实体

注意:工程图比较调色板仅在模型模式中可用。在图纸模式下使用 DrawingCompare 命令可自动将工程图切换到模型模式。

面板包含三个部分:

  • 差异:允许您在工程图中为比较结果指定颜色。
  • 云:允许您指定标记差异的修订云线的颜色、形状和大小。
  • 过滤:允许您在比较结果工程图中包括或排除剖面线和文本实体。
  • 统计数据。显示针对当前差异的报告。报告包括当前工程图中缺失的对象数以及仅在当前工程图中存在的对象数。对象按其类型进行计数。

此外,调色板顶部还有一个工具栏。

工具栏

使用工具栏中工程图比较面板顶部的按钮,查看导航和访问选项:

  • 切换比较 :显示或隐藏比较结果。
  • 后退 和前进 :允许您在差异之间导航。此外,您可以通过键入索引号来指定差异。
  • 弹出菜单包含用于管理比较工程图中的对象的工具。使用切换显示比较结果后,弹出菜单会处于启用状态。
    • 恢复 :将所有缺失对象导入到当前工程图中并删除所有其他对象。
    • 导入 :将当前选定差异中的缺失对象导入到当前工程图中。
    • 全部导入 :将所有缺失对象从比较工程图导入到当前工程图中。
    • 移除 :从当前比较结果中删除仅在比较工程图中存在的对象。
    • 全部移除 :从所有比较结果中删除仅在比较工程图中存在的对象。
  • 导出比较结果 :将比较工程图保存在指定位置。
  • 刷新 :刷新当前工程图视图。刷新图标上的橙色圆点 表示当前工程图已更改。

访问方式

命令:DrawingCompare

菜单:协作 > 工程图比较

功能区:协作 > 实用程序 > 工程图比较

使用图形标准

使用图形标准,您能够检查图形是否符合自定义标准和公司标准。

图形标准保存在 *.dws 类型的图形标准文件中。

可检查图形中的以下标准设置以实现达标:

  • 图层: 检查名称、线条颜色、线条样式和线宽属性。将忽略图层的显示和锁定设置(开/关、冻结/解冻、绘制/非绘制和锁定/解锁)。
  • 线条样式: 检查名称、线段长度和间距定义。
  • 标注样式: 检查名称和所有标注变量设置。将忽略标注变量覆盖。
  • 文字样式: 检查名称和文字样式定义的所有属性,包括字体名称、字体格式、文字高度、倾斜角度、间距、和方向设置(倒置、反向、竖直)。

本节讨论的内容包括:

创建图形标准文件

图形标准保存在 *.dws 类型的图形标准文件中。它们类似于常规图形文件,但被指定为存储图形标准。

使用 VerifyStandards 命令检查当前图形是否符合图形标准文件。

创建图形标准文件:

  1. 创建一个图形,此图形具有要应用的图层、线条样式、标注样式和文字样式的名称和属性以便进行图形标准检查。
  2. 单击文件 > 另存为(或键入 SaveAs)。
  3. 在文件对话框中,选择图形标准 (*.dws) 为文件类型。
  4. 指定文件夹和文件名。
  5. 单击保存。

  可使用现有图形作为标准文件,但要确保清除所有不希望包括的图层、线条样式、标注样式和文字样式。

关联图形标准和设置通知选项

使用 DrawingStandards 命令以:

  • 将图形标准关联到当前图形
  • 确定要检查的图形类别
  • 设置通知和审核选项

将图形标准关联到当前图形:

  1. 单击工具 > 标准 > 图形标注(或键入 DrawingStandards)。
  2. 在对话框中,展开标准。
  3. 单击新建。
  4. 在文件对话框中,指定要关联到当前图形的图形标准文件 (*.dws) 的名称。
  5. 单击打开。
  6. 另外,还可以重复步骤 2 和 3 以向列表添加更多标准文件。
  7. 单击删除以从列表中删除标准。
  8. 多个标准文件中的标准将按列表中指定的顺序进行检查。要更改优先级,选择项目,然后单击上移或下移。
  9. 在设置下,阅读有关选定标准的信息,包括图形文件名称、图形格式(发布版本)、上次修改日期和上次修改者。
  10. 单击验证标准以立即验证关联标准。此选项将运行 VerifyStandards 命令。
  11. 单击应用。

确定要检查的图形类别:

  1. 单击工具 > 标准 > 图形标注(或键入 DrawingStandards)。
  2. 在对话框中,展开图形类别。
  3. 激活要包括的图形类别以便使用 VerifyStandards 命令验证。
  4. 注意: 勾选至少一个类别以启用图形标准检查。
  5. 单击应用。

设置通知和审核选项:

  1. 单击工具 > 标准 > 图形标注(或键入 DrawingStandards)。
  2. 在对话框中,展开选项。
  3. 在通知中,选择选项:
    • 禁用警报消息: 关闭违背标准通知。
    • 在出现违背标准情况时弹出警报: 在检测到当前图形中存在违背标准情况时,显示弹出警报(默认)。
  4. 在验证标准中,指定选项:
    • 自动修复非标准属性: 指定在运行 VerifyStandards 命令时是否自动修复非标准对象(默认取消选中)。
    • 显示忽略的标准违背: 指定是否显示验证标准对话框中被标记为忽略项的违背标准情况(默认选中)。
    • 首选标准文件: 设置图形标准文件 (*.dws) 或无。
  5. 单击应用。

访问方式

命令: DrawingStandards

菜单:工具 > 标准 > 图形标准

验证图形标准

使用 VerifyStandards 命令检查当前图形是否符合行业、企业和自定义标准。

该命令将检查当前图形中的图层、线条样式、标注样式和文字样式的名称和属性是否符合关联标准文件中的规定。

您可以更换非标项目以使其符合规范、标记它们要将其忽略,或者不采取任何操作。

我们建议您在运行 VerifyStandards 命令之前,先运行 Clean 命令清空未使用的对象。

验证图形标准:

  1. 点击工具 > 标准 > 验证标准(或键入验证标准)。
  2. 该对话框中将显示违反图形标准的项目的类别和名称(例如,以 DimensionStyle 作为标注样式的类别和名称)。
  3. 在替换为中,选择图形标准。
  4. 此列表可包含多个标准,因为绘图标准文件的一个类别可能包含多个对象,或者为当前图形定义的图形标准文件列表包含多个文件。
  5. 更改预览中将显示经验证符合要求的当前项目与替换列表中的选定标准。如果项目名称不同但属性相同,则此列表为空。
  6. (可选)忽略此标准违规,以将当前项目标记为不用更换。忽略者信息显示设置忽略选项的用户的登录名。此状态是与图形存储在一起。
  7. 单击修复接受将当前项目替换为指定的图形标准。
  8. 单击下一个进行到下一个项目。
  9. 对后续项目重复步骤 2 至 5,以检查合规性。
  10. 单击关闭。
  11. 验证过程结束时,摘要屏幕会报告标准违规总数、自动修复的项目数、手动修复的项目数,以及已标记为“忽略”的项目数。

  在验证标准对话框中,单击选项,更改在验证过程的通知和审计选项。这将打开选项对话框的标准配置 > 选项部分(与调用 DrawingStandards 命令相同)。

访问方式

命令: VerifyStandards

菜单:工具 >标准 > 验证标准

Updated on 14 4 月, 2026

Related Articles